将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 113|回复: 1
收起左侧

华为H3C设备设置vlan truk模式

[复制链接]
发表于 2021-3-9 22:23:13 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
步骤:
" n7 T) y: p5 k5 ?( f$ t# Q7 Y; L$ d' g, Q) o! Z* a! m6 g  B
1.telnet 登录到交换机到控制台
- m7 `$ Z: |3 s' {. r$ t, o. D+ \; u; E
2.进入系统视图,创建 2到20的vlan
( U; D3 }: L' l6 ~
3 P9 e% @0 K3 I# T8 K3 T( \<Quidway>sys- q- D1 M; ]% w# `
Enter system view, return user view with Ctrl+Z.0 e! h2 R# k: Z
[Quidway]vlan batch 2 to 20& f" \% m' Y7 a% P! B& f
Info: This operation may take a few seconds. Please wait for a moment...done.& S/ [( w* T5 g- p& z5 e4 }* |6 B/ R
[Quidway]
8 x- e4 S6 H+ B0 N1 ?" w& ?: X: W1 ?  V6 r
3.进入37口
) F/ Q# J; j1 i/ M8 S/ v: X8 f" A$ @  H3 j0 y0 t5 b& X% ]+ F
[Quidway]int g0/0/37
3 V$ y+ U- m5 D2 ~6 ]$ }[Quidway-GigabitEthernet0/0/37]5 s; l/ w2 Y4 V& ?& Q1 \
. a& @- k4 U& `
4.设置trunk
7 m/ j2 B5 ^! d% L( {5 Y! E/ Y, c- z! [: w: ?
[Quidway-GigabitEthernet0/0/37] port link-type trunk9 e9 t- A. {/ P/ _" ?
! \* }- f! [! i' o8 V0 P
[Quidway-GigabitEthernet0/0/37] port trunk allow-pass vlan 2 to 4094' Z5 t% i/ k( J
: M1 g! ~# V& J' ~
Info: This operation may take a few seconds. Please wait for a moment.....done.
1 s4 u! l3 P% t' I  Q. x( r6 x[Quidway-GigabitEthernet0/0/37]5 q# v5 O- `, [, W( L
) U/ D- i/ n" ]; |9 Z9 p9 f: q- a
5.查看2 Y% ]2 n$ j4 ]) ]2 U3 m
4 v6 }% `" ^! g' o: w9 V
[Quidway-GigabitEthernet0/0/37]dis this  Q3 T# P8 K9 H. b3 x; }
#
  c- @( s; M  ^. X" Dinterface GigabitEthernet0/0/37
/ [" [5 J5 f7 M0 }port link-type trunk: o! ]' o3 N& X% l3 ~1 U8 T
port trunk allow-pass vlan 2 to 4094
( w; g5 F+ t6 `$ S/ d& C7 H#
* j2 p& \7 e( L" }9 j! Vreturn; S9 h. G9 A  U3 J3 \+ V
[Quidway-GigabitEthernet0/0/37]& Y' n1 G. ]6 G) E

4 R* `+ z7 f; x4 F6.38口设置参照以上3、4、5操作即可
& }, n9 r) \& d  j. p. t; w
' v5 _0 j! a; q9 L4 ]7.保存设置' r5 b+ M" D2 o% r

+ C& j9 ~3 j/ N& J% x* d9 D* w+ S; |; i" c; }7 k
交换机配置好后,如果不保存,交换机断电或者重启后,配置就会丢失。1 i, X4 W' p, ^" [' G
所以,在配置好交换机后在  用户视图 执行 save  命令,就可以将配置保存到交换机上了。 注意必须是用户视图<Quidway>执行save命令。
- Y8 `# x3 g  K8 B/ ]" R& C[Quidway]quit
* \4 F0 T3 Q8 w4 ~<Quidway> save
3 l5 _! _  C: h; R& v/ z6 R- M8 P& c- O: N* }

8 b! y; q/ l6 x; t" p/ F' finterface GigabitEthernet0/0/19      进入到设备接口
. i7 T; y/ b( i+ t" T4 n- q port link-type trunk   port端口设置trunk
1 C" f) k  P- u; J; J5 v( @& J' W, H0 x port trunk pvid vlan 10   
# `6 e7 T  q* _8 f8 |) h5 v9 y! S port trunk allow-pass vlan 2 to 4094   端口运行trunk模式下2-4094vlan可以通过
+ O% G+ m1 l; e( r( @, ]6 H, ?: ]9 T4 ?; p

, Q( d1 T% N5 t+ p0 w
 楼主| 发表于 2021-3-10 16:19:30 | 显示全部楼层
VLAN划分方法一般划分为4种,分别是基于端口、基于Mac、基于协议、基于IP子网。
( A: ?8 J& D& a, l$ i, w* P5 ~; i( Y4 B
常用基于端口划分。
) E1 A4 g- [- g$ y% d% l; ]
' G& }- Y# O$ M一、基于端口的VLAN配置案例3 Q0 K! U7 f. z8 T. E/ B1 d+ ~
' f' w/ k! G, W
" I1 S& N4 p' X3 ~( S
二、基于Mac地址的划分9 _4 j, v# D4 D3 k
. L- Q0 ^+ L$ `* E5 L5 E* x2 u& |
1. 组网需求) s' X$ [. u! y. \4 z& R* Z9 \
l              如图1-6所示,Device A和Device C的GigabitEthernet1/0/1端口分别连接到两个会议室,Laptop1和Laptop2是会议用笔记本电脑,会在两个会议室间移动使用。
8 @, r: ]# d. w" `- p/ J0 a! Z- f; J0 n& @1 x$ b
l              Laptop1和Laptop2分别属于两个部门,两个部门间使用VLAN 100和VLAN 200进行隔离。现要求这两台笔记本电脑无论在哪个会议室使用,均只能访问自己部门的服务器,即Server1和Server2。1 Z* @: }+ y- J7 W9 K2 `( u
5 s" a' u( i. @  y) l; b$ \
l              Laptop1和Laptop2的MAC地址分别为000d-88f8-4e71和0014-222c-aa69。& e* |& i: C; z( f

5 C# B, P0 |/ v" C
. n8 V/ s, l, ~7 K  [& G
, F) r. U& j! Y  J' C* K
# `, x" V+ E( j7 j9 z  d! s
; d. A) j- w: V  k1 H* t0 W. R& U3. 配置思路4 P  r. B( N7 j& R
l              创建VLAN 100、VLAN 200。
; @4 M( j& {% E& T7 b
9 p8 J6 ]3 S& a7 G9 ~3 ^0 zl              配置Device A和Device C的上行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过。8 @9 l  F, T4 t+ ?" h* C
$ _& F2 S" E# J2 h( X
l              Laptop1和Laptop2的MAC地址分别与VLAN 100、VLAN 200关联。
/ @+ x: A% ^4 o7 d5 R# k$ ^/ W  S, \+ M/ X; t9 @) e9 x
4. 配置步骤
/ B' F! A6 b( a7 ^. ~(1)        Device A的配置
( h* ^) P6 a5 e8 ?! }6 C
3 q4 L) _4 S2 ~; e2 M: ?% e$ y  s& P# 创建VLAN 100和VLAN 200。
4 o6 S; T5 N: X* g- B. R) v3 K; ]
% H6 U+ i7 r- b9 v! S& D2 P<DeviceA> system-view7 {/ `3 Y3 I! b

+ E/ {) y' U, n) {# _( r[DeviceA] vlan 1005 D. Y, P1 [' b6 A5 z

  m* O( p4 g- z% w3 I[DeviceA-vlan100] quit
+ _! f9 h. K) n0 @4 R7 K
0 H& S1 w* v# F9 u, j: H[DeviceA] vlan 200
# M6 }6 _- ^7 b  }$ d# ~6 @! o5 |( K, f8 ^+ [% s
[DeviceA-vlan200] quit( B) H- K; P; O( `$ x

( r+ g$ I; @8 x) L$ m& m9 V+ N# 将Laptop1的MAC地址与VLAN 100关联,Laptop2的MAC地址与VLAN 200关联。
/ c" S7 @' b; m5 P, F" |/ N+ F% C3 L* k) o1 V6 d% S* S6 z  ?$ p
[DeviceA] mac-vlan mac-address 000d-88f8-4e71 vlan 100
6 P* l% w% h- ^: U
4 ]' R$ M+ d& s[DeviceA] mac-vlan mac-address 0014-222c-aa69 vlan 200
2 ?# O3 `5 E. H  G$ X' F" }1 w
+ V1 ?+ X8 ^& z2 T# 配置终端的接入端口:Laptop1和Laptop2均可能从GigabitEthernet1/0/1接入,将GigabitEthernet1/0/1的端口类型配置为Hybrid,并使其在发送VLAN 100和VLAN 200的报文时去掉VLAN Tag;开启GigabitEthernet1/0/1端口的MAC-VLAN功能。
1 M5 X1 z1 k) M/ N/ N0 U
- y7 A% Z4 P3 M1 r; `( g[DeviceA] interface gigabitethernet 1/0/1. ?/ M/ k; K: C  y( a3 m5 Q+ V
# M# p9 O/ q6 @+ w0 O7 l
[DeviceA-GigabitEthernet1/0/1] port link-type hybrid
2 y: l4 f9 {  A* R- S* H1 U1 M, T
[DeviceA-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged& l, g4 L- Y; X6 W& G3 }

# ~0 o! w( @) i Please wait... Done.$ \. U4 k  f% Y% t8 V
! V1 n9 |& p" S+ g
[DeviceA-GigabitEthernet1/0/1] mac-vlan enable8 k' u5 k" |, v( Z
% {5 D3 Z+ Y+ v2 c; `4 t
[DeviceA-GigabitEthernet1/0/1] quit
9 M/ I) m% ?( G
9 t/ V$ }  o8 F$ b1 {* E& X- {. D# 为了终端能够访问Server1和Server2,需要将上行端口GigabitEthernet1/0/2的端口类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过。
2 @& `3 `6 j' O6 W0 Y
) ~- p; {6 S# z  j/ f[DeviceA] interface gigabitethernet 1/0/2! f; i1 T" r1 @% N9 m6 A

1 l3 J" {4 T9 [1 e+ b" c& [  R$ n8 h[DeviceA-GigabitEthernet1/0/2] port link-type trunk
# b, h! r  N4 m
. ~, w2 j) O* ]5 _+ f7 u4 w" g[DeviceA-GigabitEthernet1/0/2] port trunk permit vlan 100 200( m! d6 C3 R% o( n

' G, e1 n+ m' ~. u! F% o3 ~[DeviceA-GigabitEthernet1/0/2] quit
9 U* P% d3 i# S, A8 W1 V: G- v1 \5 ]% u# ~7 w, p
(2)        Device B的配置
8 d- X& e: E' o2 B" Q5 L2 O7 C  \& c4 Y( v, S
# 创建VLAN 100和VLAN 200,并将GigabitEthernet1/0/13加入VLAN 100,GigabitEthernet1/0/14加入VLAN 200。2 V' k. F5 p; ~

/ I+ p" f% f: L% m<DeviceB> system-view3 [& U3 v( |( p5 e4 B  t

. ^* S% o9 l3 C6 t0 P[DeviceB] vlan 1006 p1 i' F3 ^7 ~6 Q- T& O( y

* P, L, U0 p: e2 c) B# @[DeviceB-vlan100] port gigabitethernet 1/0/13
/ A4 Z" A( R  w: L
: ~; M- _. _2 q[DeviceB-vlan100] quit
9 j; |- X) J3 h& A# l
- }9 Y* v! l1 [5 M[DeviceB] vlan 2006 g0 |6 [* L- |$ [6 ]" a1 ?& ^" k

: R3 [2 H, i, }1 v6 l[DeviceB-vlan200] port gigabitethernet 1/0/14
/ y. a. P9 u5 e: b7 ]9 l& q
& p6 }) c8 o2 E[DeviceB-vlan200] quit$ @; Q+ [( x  @/ u- L
. c% Z' v8 U, s0 z7 y/ g
# 配置GigabitEthernet1/0/3和GigabitEthernet1/0/4端口为Trunk端口,均允许VLAN 100和VLAN 200的报文通过。
3 o6 s3 ]4 V! w  ~) D4 E
1 u# v- x/ ?/ p8 z2 Z* \" N[DeviceB] interface gigabitethernet 1/0/3
$ p6 p7 G& n3 E
) l! l8 l1 [! @+ u' [; [3 ][DeviceB-GigabitEthernet1/0/3] port link-type trunk
' L, F, O& W6 l! |4 _0 P4 ?  o  h/ s# `( |
[DeviceB-GigabitEthernet1/0/3] port trunk permit vlan 100 200# ^( }! A  ~. m" T

3 E2 a9 o/ W% }' Y; d# `+ _/ b[DeviceB-GigabitEthernet1/0/3] quit/ S/ M% _7 R% X3 q! K4 s+ ~

- R% j  P$ T  B2 }: O9 g[DeviceB] interface gigabitethernet 1/0/4/ C, x6 M3 a9 @1 n) \2 u6 A5 |
: ]1 V& D; S/ N  n2 x# b5 ^
[DeviceB-GigabitEthernet1/0/4] port link-type trunk2 B4 ~0 |; v- V9 H( Y

* R% d8 G+ r/ }[DeviceB-GigabitEthernet1/0/4] port trunk permit vlan 100 200
8 N/ F7 i& k, ]' z/ E4 m! h, D# f+ J: z3 H4 @. o# i/ q6 a- T+ l, ]
[DeviceB-GigabitEthernet1/0/4] quit; B7 }! |  T5 i( S$ e! J

! i: ~6 G4 i4 C(3)        Device C的配置
/ H2 |5 j! u+ L, _" l
# k% E, e, F( [6 q5 [3 ]' n) U! EDevice C的配置与Device A完全一致,这里不再赘述。
4 v6 G% U. @* `0 D( H/ }' Z
" X; c9 W5 q% z" b三、基于协议的划分0 h" x3 `5 B# P2 |& y
* D! N& Z6 z9 Z3 X" a. K' L
1. 组网需求" o- E  T& L- I6 D4 T- o. i
实验室网络中大部分主机运行IPv4网络协议,另外为了教学需要还布置了IPv6实验局,因此,同时有些主机运行着IPv6网络协议。为了避免互相干扰,现要求基于网络协议将IPv4流量和IPv6流量二层互相隔离。: P- r9 j2 ^8 \1 E+ I! P

, ?4 B2 P9 D8 M+ p$ S% c2. 组网图
- y8 h3 s, _3 g6 W! n
4 `2 n) }( i: ^0 h
/ G7 A$ o0 T9 O ' H, {* O6 G$ R

/ g/ w' u2 Q/ R$ r& \6 e3. 配置思路8 B% p9 C0 T4 }7 [. }
创建VLAN 100及VLAN 200。让VLAN 100与IPv4协议绑定,VLAN 200与IPv6协议绑定,通过协议VLAN来实现IPv4流量和IPv6流量二层互相隔离。- h. T$ j# R" ~0 }2 e# e9 r( G
* `9 a) \+ m6 a9 u; A1 Q
4. 配置步骤
0 r0 O  t3 C3 R5 [  L9 ?(1)        配置Device+ J, J9 k  G% O9 \
* H" e( E" `1 J- X3 l* W
# 创建VLAN100,将端口GigabitEthernet1/0/11加入VLAN 100。
5 F3 U& c& l' m0 @; o7 B6 Y3 q
<Device> system-view8 a1 E2 c2 V* Z! r# X

9 h& P2 v; K* m# u- N. z+ J[Device] vlan 100  ^0 t1 l. V$ \# D5 z( V6 ~' _( J

; ~8 \9 R! x0 y* y0 j: }[Device-vlan100] description protocol VLAN for IPv4
: {+ U8 y( s0 Y
. q# A- Z/ ?6 }# P4 W% X  D& n[Device-vlan100] port gigabitethernet 1/0/11
7 }! [9 S2 }. K6 U* R; Y
/ x. M/ t: ~- S[Device-vlan100] quit
) ?6 e0 d7 I  _, O+ o8 m& ~
% g, e$ S% n+ T# 创建VLAN 200,将端口GigabitEthernet1/0/12加入VLAN 200。
4 q. s& N, Y1 t0 x" @; Z( d
, C3 `9 O1 C5 A  g/ P[Device] vlan 200) m1 ], e* G9 W7 u
( y; h( I& M# t% U; H0 h, v/ Y4 e
[Device-vlan200] description protocol VLAN for IPv6
# [! R, q; a: f& y& C% T3 g2 y8 a
2 ~5 a3 ~, ?, ?" c+ N[Device-vlan200] port gigabitethernet 1/0/12
+ S4 S8 V' A5 P! _% w5 z
) Z1 y  ~- x3 m, u# O) j+ g0 c5 ]# 在VLAN 200和VLAN 100视图下,分别为IPv4和IPv6协议创建协议模板。
# S8 Y& j( l1 q
7 `2 y3 n" b2 H. X& f9 ?[Device-vlan200] protocol-vlan 1 ipv6
( k6 z1 C$ ]) ^! M1 d$ U" [) c+ h6 `
[Device-vlan200] quit$ I1 o" O: @0 ?4 Q& F2 R

" P! w8 E9 ]6 w7 ]2 ]9 e0 h1 L[Device] vlan 100  h7 n: m! ^3 p, Y3 r4 M, q
5 F5 J+ q3 t# ]* U' I
[Device-vlan100] protocol-vlan 1 ipv4
+ [0 l# R5 v1 `* P0 _( e" H' Q) D" @
[Device-vlan100] quit
" X, C; L- p. c
% l! W1 B' P& {1 J, G% g6 t2 r+ H& L8 ^# 配置端口GigabitEthernet1/0/1为Hybrid端口,并在转发VLAN 100和VLAN 200的报文时去掉VLAN Tag。3 S* b# q  z4 I: {

# _7 E" L8 n) ^* t, _; ~5 `; ~$ n[Device] interface gigabitethernet 1/0/1
' r8 i8 _" }2 x0 Z3 c" u, N4 A/ U3 d
[Device-GigabitEthernet1/0/1] port link-type hybrid
( d* S  l( A+ H( }
& \- B+ R- t  i% H[Device-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged
9 h4 Z6 W0 H8 c. P5 ]
! `7 g' U( J9 S# S  A; a; k Please wait... Done.  w1 @' W4 M+ C$ b* n* Q5 \

9 O# [( z5 O3 O) M# 配置端口GigabitEthernet1/0/1与VLAN 100的协议模板1(即IPv4协议模板)、VLAN 200的协议模板1(即IPv6协议模板)进行绑定。
. a) Y( h. N7 O. {- w
9 n3 N* U$ T8 Z+ \[Device-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 100 1- `, a' z& j- L0 Y/ q; B

! H. X% A9 r. H! S% i[Device-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 200 1
" Y: D' I! w" |8 w
$ T$ y0 s/ Q- H" z: t, B& V[Device-GigabitEthernet1/0/1] quit
& a3 i+ e) R7 s6 {) c  X- W0 v
7 P, t* k* Q6 Y' y/ a' X, H# 配置端口GigabitEthernet1/0/2为Hybrid端口,在转发VLAN100和VLAN200的报文时去掉VLAN Tag,与VLAN 100的协议模板1(即IPv4协议模板)、VLAN 200的协议模板1(即IPv6协议模板)进行绑定。! K4 w% {  S4 W. w' w

5 h( `% f( ~, d[Device] interface gigabitethernet 1/0/27 [/ U! I- c3 W0 G& d7 \9 t( [

! t7 ]7 I4 R7 N3 n# @( B[Device-GigabitEthernet1/0/2] port link-type hybrid
. Y. y. L1 s3 d1 d# F. {3 v4 T  \7 L
[Device-GigabitEthernet1/0/2] port hybrid vlan 100 200 untagged
# K4 @( K9 e# U' w+ d1 }  {0 m5 o. h1 |, \! f9 F) ]
Please wait... Done.
( ~: f% s4 Z: F/ V
, f% ]" {- N9 l& M( T- u# G% g[Device-GigabitEthernet1/0/2] port hybrid protocol-vlan vlan 100 1
2 [4 f+ R& W" \& R$ A
! m2 q7 s, r' `3 v  a  e[Device-GigabitEthernet1/0/2] port hybrid protocol-vlan vlan 200 1- O, r2 P: e! I
1 J2 F+ J  _; g/ x8 i
(2)        L2 Switch A和L2 Switch B采用缺省配置。
0 K4 a8 y0 |' g' c3 y$ p( g( m7 l
(3)        将IPv4 Host A、IPv4 Host B和IPv4 Server配置在一个网段,比如192.168.100.0/24;将IPv6 Host A、IPv6 Host B和IPv6 Server配置在一个网段,比如192.168.200.0/24。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-4-13 09:53 , Processed in 0.059556 second(s), 23 queries .

Powered by 龙睿 bbs168x X3.2

© 2001-2020 Comsenz Inc.

快速回复 返回顶部 返回列表