将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 3049|回复: 2
收起左侧

VLAN接口动态获取IP地址配置

[复制链接]
发表于 2018-5-23 21:17:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
VLAN接口动态获取IP地址配置; `- z1 Q: P  }8 U6 ^9 \
. _2 [9 Z3 Y+ G" I( S
『配置环境参数』
- m6 F5 j8 k1 T2 {5 e
: O/ `& Q# n- d$ I& ~# T2 m; t8 D1.SwitchA为二层交换机,管理VLAN为VLAN10' U6 u/ Z9 c# C( C0 e. r

0 r8 I& \$ Q; G3 E" w2.SwitchA的以太网端口E0/1为Trunk端口,连接到SwitchB,同时SwitchB提
% _# G, K: `$ i供DHCP Server功能
! W; [" f) N! L# A  k$ r" f6 @
7 Q: {% @2 f6 A- I『组网需求』
- M9 j& d* d1 D5 _" k2 @6 \4 x8 ?) A+ r( D7 s0 J0 ]8 ]3 s) ?6 Z
SwitchA的VLAN接口10动态获取IP地址数据
! Q8 e& |1 j% K& J2 [. t5 U
" H4 m/ j" m2 i& |配置步骤
& w% {; a" q% b) _
: W3 t! M1 N6 g7 p『VLAN接口动态获取IP地址配置流程』
- h+ A, d% s% u4 a" }& w9 C  U3 J# O
在VLAN接口上配置动态获取IP地址。
; w( g7 L2 L5 w4 f! X4 s8 [4 M3 F1 u9 z4 T4 v0 u
【SwitchA相关配置】, I6 v# N  ^6 @: o7 h

& c- R2 G# h- K; ?( {1.将E0/1端口设为trunk,并允许所有的vlan通过4 s* L$ r2 v/ }9 E) b" x2 D
, [2 Q' N, O$ l
[SwitchA-Ethernet0/1]port link-type trunk
# l, x* M% E" j* ^# v
$ M/ j( _. ^. U" h0 N: R5 h7 g[SwitchA-Ethernet0/1]port trunk permit vlan all! Q  A2 U& }7 J4 b3 f! E) D
: ]7 |3 A: t  V% t% ^
2.创建(进入)VLAN10
, |# [2 Y. a2 J" f
& c, y) M- x, S2 W/ p% \) ~[SwitchA]vlan 10
 楼主| 发表于 2018-5-23 21:20:45 | 显示全部楼层
配置中继3 C7 }  v/ l; e) Q, Y1 \# ~+ t9 j
步骤 交换机1命令 交换机2命令 作用/ {8 W( T1 {/ ?( @; t: y
1 SW1#config terminal SW2#config terminal 进入特权模式. o3 w5 u, r" r& ~: l
2 SW1(config)#interface f0/24 SW2(config)#interface f0/24 进入接口配置模式
. ]7 W5 T+ S4 v- |* a6 A3 SW1(config-if)#switchport mode trunk SW2(config-if)#switchport mode trunk 将F0/24口配置为中继7 L, q8 c( z8 n' b  e, V- N
4 SW1(config-if)#end SW2(config-if)#end 返回特权模式
  b4 t, O, b- C& p' j5 SW1#show interface f0/24 switchport SW2#show interface f0/24 switchport 查看F0/24的中继状态" g1 }4 ^- w+ |. M
四、将接口加入vlan3 F9 |9 c& C3 F7 ^7 Y8 \, a
步骤 交换机1命令 交换机2命令 作用. `0 c  d# k- ~; R- q
1 SW1#config terminal SW2#config terminal 进入特权模式
/ L3 ^5 E, ^6 G: f: g2 SW1(config)#interface range f0/1 - 10 SW2(config)#interface range f0/1 - 10 进入接口配置模式
3 d. m2 L' E+ a* P( zSW1(config-if-range)#switchport access vlan 2 SW1(config-if-range)#switchport access vlan 2 将f0/1-10分配给valn2
1 |- K8 t+ m; a3 J1 ~0 FSW1(config-if-range)#interface range f0/11 – 20 SW1(config-if-range)#interface range f0/11 – 20 进入f0/11-20的接口配置模式
. ?2 h! k" M9 RSW1(config-if-range)#switchport access vlan 3 SW1(config-if-range)#switchport access vlan 3 将接口分配vlan 32 q* S( G8 ~& j( p
SW1(config-if-range)#end SW1(config-if-range)#end 返回特权模式/ M* Q# d5 ^' U* E
SW1#show vlan brief SW1#show vlan brief 查看vlan 情况
发表于 2018-5-23 22:40:51 | 显示全部楼层
用交换机根据端口划分vlan。2 M- b/ `* d  e! z/ U5 d' O
switch#vlan database$ W3 v: @, u% H: X3 K2 g
switch(vlan)#vlan 10 name v1/ @" J/ K8 n% n6 c3 L8 `: q  I
//此步为划分出一个id是10名字是v1的vlan
3 i" ]0 E: q# D) p+ `1 Tswitch(vlan)#exit5 x3 K5 W- a6 Y* ^
switch#configure terminal
& c3 V1 \6 E" D5 W( e8 r% k. hswitch(config)#interface f0/1+ ~( a" U' s3 b/ y
switch(config-if)#switchport access vlan 10
# S8 R+ p4 O3 s. U/ ^0 P//此步为把f0/1划分给vlan 10,即与f0/1相连的计算机划分给vlan 10。3 B# C: q; D1 s% P6 I
switch(config-if)#interface f0/2
+ G, t! J0 b# ~9 j0 q+ e/ Q  X( Dswitch(config-if)#switchport mode trunk0 P6 h# Z2 b' N' V! B* _# F, R
//f0/2为交换机间的接口。
7 `( p; g0 K' u' ^//此步为把两台交换机间的接口配置成trunk模式,以便不同vlan能通信。
: f+ d6 ?# @- _) O如果要实现线路冗余,可在交换机间配置快速生成树。2 M# ~8 ?( M# f
switch(config)#spanning-tree vlan 10+ ~7 _& P% {, E  ^7 {: G% f& r
switch(config)#spanning-tree mode rapid-pvst3 L+ w/ N) X: n( u# `
用路由器实现vlan间通信,防止外部访问本公司网络。
4 |; S9 f; H* J4 j8 A+ Grouter(config)#interface f0/2
& Q3 h  P# K( d; \//f0/2为路由器与交换机之间的接口。' H3 u- |6 i& ?
router(config-if)#no shutdown$ \0 q) I8 L! R; t
router(config-if)#interface f0/0.106 O6 F! C: `2 E' u$ N) D
router(config-subif)#encapsulation dot1q 10$ \8 C9 ]* n9 f
//10为vlanid
: ~% ^( p' q4 _6 j$ j! Y! Hrouter(config-subif)#ip address 192.168.1.1 255.255.255.0
  F; u" m9 T) X2 Q1 T//此步为配置单臂路由,实现vlan间通信。5 |. i" `, p" z% m
router(config)#access-list 1 deny 10.10.1.0 0.0.0.255
8 [6 J% o9 s# t4 T( @4 brouter(config)#access-list 1 deny 10.10.2.0 0.0.0.255
' w3 x7 M0 L/ T3 a' d; P: v//10.10.1.0和10.10.10.2.0为内网ip。: w: o  J1 u, |- o+ S/ h' Y
router(config)#access-list 1 permit any9 U0 ^: e1 B( W# A' R) G1 q
router(config)#interface f0/0/ z7 R* d- I5 n( M
router(config-if)#ip access-group 1 out
0 z1 {$ G5 {& ^$ J& B; [  `: Y//f0/0为路由器与外网接口。* z  o) P7 p; M$ v# N1 z
//此步配置访问控制列表,限制外网访问内网。
( U) M- r! ?% ?( O5 ^% d& J以上配置全是思科的设备。
+ C5 y, W( |6 [* V内部网络用私有ip地址即可。私有ip地址网段分别为10.0.0.0-10.255.255.255和172.16.0.0-172.31.255.255和192.168.0.0-192.168.255.255
$ Z" `( D" J# D# p2 n' A, k不同vlan的ip可以在同网段,也可以不同。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-4-13 08:22 , Processed in 0.492142 second(s), 22 queries .

Powered by 龙睿 bbs168x X3.2

© 2001-2020 Comsenz Inc.

快速回复 返回顶部 返回列表