将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 87|回复: 1
收起左侧

centos8安装rabbitmq报错

[复制链接]
发表于 2021-3-18 12:16:10 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
Last metadata expiration check: 0:25:55 ago on Fri 19 Mar 2021 11:45:11 AM CST.
9 C  X2 z7 H: b/ i" d3 I4 RError:
2 }) G! c0 Y4 D6 v Problem 1: package erlang-22.3.4.1-1.el8.x86_64 requires erlang-wx(x86-64) = 22.3.4.1-1.el8, but none of the providers can be installed
; t6 ~. L6 f/ k9 Z/ D+ F  - package erlang-wx-22.3.4.1-1.el8.x86_64 requires libwx_gtk3u_core-3.0.so.0(WXU_3.0.5)(64bit), but none of the providers can be installed
% S% v$ e' T  J# l1 O2 w  - cannot install the best candidate for the job3 m/ g6 F$ t7 [. \4 I
  - nothing provides libSDL2-2.0.so.0()(64bit) needed by wxGTK3-3.0.5.1-1.el8.x86_64% z$ M0 Q$ J, q1 c0 X
Problem 2: package erlang-lager-3.8.0-2.el8.noarch requires erlang-common_test, but none of the providers can be installed4 U% M9 M$ n4 a& ~
  - package erlang-common_test-22.2.8-1.el8.x86_64 requires erlang-observer(x86-64) = 22.2.8-1.el8, but none of the providers can be installed
# Z- ?/ B( i/ ~  - package erlang-common_test-22.3.4.1-1.el8.x86_64 requires erlang-observer(x86-64) = 22.3.4.1-1.el8, but none of the providers can be installed: [9 n& _$ K/ c1 k! O, p
  - package erlang-cuttlefish-2.0.11-10.el8.noarch requires erlang-lager, but none of the providers can be installed
$ Y# _5 ~4 C- N' v% w  - package erlang-observer-22.2.8-1.el8.x86_64 requires erlang-wx(x86-64) = 22.2.8-1.el8, but none of the providers can be installed
; i6 Y6 c+ W/ u; v8 o  - package erlang-observer-22.3.4.1-1.el8.x86_64 requires erlang-wx(x86-64) = 22.3.4.1-1.el8, but none of the providers can be installed
3 o: d1 U: Y  o- G9 B# d5 u) @  - package rabbitmq-server-3.8.3-1.el8.x86_64 requires erlang-cuttlefish, but none of the providers can be installed/ X- _/ |+ w+ x- i4 h0 s
  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_core-3.0.so.0()(64bit), but none of the providers can be installed( U! v. H6 c9 u  R; [2 B
  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit), but none of the providers can be installed
0 E0 `" M: M% G7 g4 G  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_adv-3.0.so.0()(64bit), but none of the providers can be installed! V; O* ]8 i4 c  ]4 p. r9 g3 q
  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_aui-3.0.so.0()(64bit), but none of the providers can be installed
+ Y, W! Y1 `. E- k& g3 e' v  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_html-3.0.so.0()(64bit), but none of the providers can be installed
* P8 T$ G9 g7 j. Y( Q: r" d  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_stc-3.0.so.0()(64bit), but none of the providers can be installed4 a- N, l; o- H* J, g
  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_xrc-3.0.so.0()(64bit), but none of the providers can be installed
: }/ O( l5 U& A* S  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_adv-3.0.so.0(WXU_3.0)(64bit), but none of the providers can be installed, _( s* x& S* ~% K
  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_aui-3.0.so.0(WXU_3.0)(64bit), but none of the providers can be installed
+ W8 ^, m4 F" W# j% s5 ]  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_html-3.0.so.0(WXU_3.0)(64bit), but none of the providers can be installed6 [! D% _4 P2 G& c/ E1 Q8 ^3 @
  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_stc-3.0.so.0(WXU_3.0)(64bit), but none of the providers can be installed
3 k: J3 T* Y- N1 ?4 i4 h# h  - package erlang-wx-22.2.8-1.el8.x86_64 requires libwx_gtk3u_xrc-3.0.so.0(WXU_3.0)(64bit), but none of the providers can be installed
5 E7 A( k4 H# |9 ^+ L  - package erlang-wx-22.3.4.1-1.el8.x86_64 requires libwx_gtk3u_core-3.0.so.0(WXU_3.0.5)(64bit), but none of the providers can be installed' Q1 M" V2 }6 ~2 ^- k* s9 `
  - cannot install the best candidate for the job$ b$ i/ |8 s: Y8 L" J" x' X
  - nothing provides libSDL2-2.0.so.0()(64bit) needed by wxGTK3-3.0.4-15.el8.x86_64; i, ], l7 R5 X! O! r% |
  - nothing provides libSDL2-2.0.so.0()(64bit) needed by wxGTK3-3.0.5.1-1.el8.x86_648 b0 ?) n3 |; `' R+ y9 d' W  C" Z; U
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)% M( Q- g" ~+ F, E$ V
 楼主| 发表于 2021-3-18 12:59:58 | 显示全部楼层
添加一个repo文件即可:
0 g0 e: d% v3 i1 R" PCentOS8的rabbitmq服务yum源配置:
4 z' Y' ]% [% {! ~8 tvim /etc/yum.repos.d/rabbitmq.repo0 \* M' @. c5 w! Q
+ D1 |( R+ k! l( T+ W
[bintray-rabbitmq-server], {9 R; g" f3 n/ n0 T* V
name=bintray-rabbitmq-rpm+ I% C8 j  `& v6 Y% t$ p* K! c6 K
baseurl=https://dl.bintray.com/rabbitmq/rpm/rabbitmq-server/v3.8.x/el/8/  p) H, R% Q5 ]$ P' W! }
gpgcheck=0
. O4 A# Y* Q. n/ E: u4 Crepo_gpgcheck=01 G3 E) ~. a2 U) o6 E' J8 P
enabled=1' U! q9 G2 f0 \  c' H" }5 N& j

8 G5 Q1 p. T' W0 `/ xvim /etc/yum.repos.d/rabbitmq-erlang.repo5 P, T* u: u5 D. r
0 j( k8 K) H7 I. m/ c; z/ [+ x
[rabbitmq-erlang]
# q' J" {, {4 u9 z- W( Xname=rabbitmq-erlang
1 w" V5 L" P4 ^7 z' V7 d# A+ }- d2 Gbaseurl=https://dl.bintray.com/rabbitmq-erlang/rpm/erlang/22/el/8/
  g$ ]: o  r2 a, c0 Q" I) [gpgcheck=1$ V! E0 Y% [* Y2 t) T
gpgkey=https://dl.bintray.com/rabbitmq/Keys/rabbitmq-release-signing-key.asc
6 X4 `& c1 X) _5 t8 `3 C7 E: O7 qrepo_gpgcheck=09 L1 Y2 _& Q& C
enabled=1 5 ]' s; O& A, C
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-4-13 09:42 , Processed in 0.059742 second(s), 23 queries .

Powered by 龙睿 bbs168x X3.2

© 2001-2020 Comsenz Inc.

快速回复 返回顶部 返回列表