将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 176|回复: 4
收起左侧

CISCO(思科)交换机VLAN配置

[复制链接]
发表于 2021-2-20 22:27:17 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x
1、创建多个VLAN% X8 w* N% z: z# f3 u% I6 d. W, m
Switch>enable    (进入特权模式)
( Y. t$ x. b: y/ t5 ^7 S4 USwitch#vlan data    (进入vlan配置模式)
' g8 H4 m1 c; U$ |4 Y+ HSwitch(vlan)#vlan 10 name IT    (划分vlan10,名称为IT)
2 Y. t7 Q( X1 VSwitch(vlan)#vlan 20 name HR    (划分vlan20,名称为HR)
# |5 }: K+ Q/ y1 b5 z- A: N( eSwitch(vlan)#vlan 30 name FIN   (划分vlan30,名称为FIN)" f% |: W* b' m- O! N9 i8 n- I
Switch(vlan)#vlan 40 name LOG    (划分vlan40,名称为LOG): ~/ d$ b# o& y  h  ~' c
Switch(vlan)#exit8 i7 Z1 c! D9 V8 M
Switch#wr
7 x' O: Q# f. f* q) A  Q/ n$ l. u237-2.jpg1 ^0 L/ o2 r* I  U' o
( D+ r+ X$ I; T) G+ |0 k0 f. U3 N
2、分配端口为VLAN6 l% X4 d7 t( ~1 |: r& k
Switch#config terminal
3 s% b' w4 K* U$ O+ _1 qSwitch(config)#interface f0/1    (进入端口f0/1). H% J4 u- x  ^, G! d" E
Switch(config-if)#switchport access vlan 10    (端口f0/1分给vlan10)
6 [) |  Q# |3 [3 p  I& e4 {Switch(config-if)#interface f0/2    (进入端口f0/2)
( N4 K' c) \  \/ R! hSwitch(config-if)#switchport access vlan 20    (端口f0/2分给vlan20)" u8 p% }/ U6 f. i6 ~8 U
Switch(config-if)#interface f0/3    (进入端口f0/3)
. H0 q/ d# C+ hSwitch(config-if)#switchport access vlan 30    (端口f0/3分给vlan30)4 r, q2 x4 W) j! ]) v) T8 |9 U$ f9 Y
Switch(config-if)#interface f0/4    (进入端口f0/4)+ U6 F6 R5 b3 s' {0 z5 }; W3 G6 n
Switch(config-if)#switchport access vlan 40    (端口f0/4分给vlan40)( g4 v& n# R: R. Z! |
Switch(config-if)#end
+ p4 a8 F& ?; Q+ ^& [9 X. WSwitch#show vlan bri    (查看VLAN信息)$ K6 o( K: ?4 v# l8 v
" s" \7 [  [- r7 e
237-3.jpg# h5 \& E! I5 t, X! ^% y
Switch(config)#int range f0/5 - 8    (进入端口f0/5 - f0/8)/ v- \8 P0 A+ Y, L
Switch(config-if-range)#switchport mode access   (配置端口f0/5 - f0/8模式为access)% B8 a5 ]: M9 H
Switch(config-if-range)#switchport access vlan 10   (分配端口f0/5 - f0/8给vlan10)
6 P; ^8 G( ]" ^' x* `+ v( LSwitch(config-if-range)#exit- N% T3 W4 A& M2 o. F7 f
Switch(config)#int g0/1    (进入端口g0/1)
( z8 r) e1 m* Q. S1 E7 ASwitch(config-if)#switchport mode trunk   (配置端口g0/1模式为trunk); O( b% |$ u, e) Q  w& j  f
Switch(config-if)#end: t" \8 t, H1 P
237-4.jpg% {! |; M6 _; q) R
3、从VLAN中删除端口
0 _( Y( r; f9 w/ `. A
+ m& o9 B2 W7 C1 ~Switch#config terminal
; {2 M: ^& S, K+ b$ fSwitch(config)#interface f0/1    (进入端口f0/1)5 g  V. a0 O, L5 S: O/ N( W; Y  R
Switch(config-if)#no switchport access vlan 10    (把端口f0/1从vlan10中删除)* E' |; l3 f! [/ l+ g
Switch(config-if)#end
" ^9 z, `% c9 ~8 A& t! ~Switch#show vlan bri     (显示端口已经回到默认的vlan1)- d. k" a7 u9 I9 o1 l2 X) Z
8 f9 K, f6 \* }  ^4 z8 x
237-5.jpg
9 k5 y% K+ P) s0 t, X* ^% ]4、删除VLAN
; w- A& M$ _/ w, {: q  c/ }Switch#vlan data( `6 U6 w8 C5 c" i/ I6 ?- ?
Switch(vlan)#no vlan 10( {7 T- j6 e- K: d3 g
Switch(vlan)#exit
$ ?' d% v3 e3 N0 ]Switch#show vlan bri        (显示端口f0/5 - f0/8未回到默认vlan1)4 Z: ^8 [! p1 o( _5 X1 l& ]
Switch#show int status       (显示端口f0/5 - f0/8还在vlan10)  e  V% M7 H% _# S" Z/ M* c
237-6.jpg
6 P& z2 \+ N2 s# R: }237-7.jpg9 H0 \* j, \  h* f  i# J- [
$ c" m- d: Z0 c, U4 q2 x5 \) }5 [
 楼主| 发表于 2021-2-20 22:29:20 | 显示全部楼层
如果我公司有两条外网接口分别是A和B双线。下面的交换机上划分多个vlan其中一个vlan走A线 其余vlan 走B线 ,用技术怎么实现、我一时未能答复出来,嘿,工作就这样从我的身边走过,回到家中想到解决办法,请看下面的配置、! I9 J, S7 d2 [' d
6 ^9 \2 a7 d5 d# {% x6 j
试验目的:交换机穿建三个vlan分别为 vlan10,vlan20,vlan30 其中vlan10 走A线 vlan20.vlan30 走B线8 t& U$ B' T+ b6 F5 t

' L/ D' \8 B9 n2 i% \一试验拓扑:
1 P5 ]5 `+ \- |0 w( ^. {1 i7 y: N- K: ~: U6 a& D+ I0 Y8 Z) y

/ Z, O# x$ ~% L$ g; ~4 o' x  _# C
) o# e; _& a% Q; `/ V2950系列配置VLAN间路由步骤:# a, M$ D5 Y+ D) S% D: o
0 |' Q2 B1 A! G" [; D
R1(confi g)# int s1/07 X; J2 z4 h, v$ [' ^. O1 ]0 p

; B$ w; G+ ^  }. P  _: sR1(confi g-if)#ip add 172.16.1.1 255.255.255.0
1 a+ H: U  j) `  P4 e7 @) a' a) w* k) w7 J2 ~# G; j' ?
R1(confi g-if)# no shut
# y1 m  @/ ~" H- s' @0 u
5 ^, u# M3 _) a3 KR1(confi g)# int s1/13 l# D# q/ \3 C4 D
! G0 I) H1 V  T8 |
R1(confi g-if)#ip add 172.16.2.1 255.255.255.0; Y. I1 p, q1 R$ \% m3 c4 M
9 ?- e3 a# a8 b- V4 @. n
R1(confi g-if)# no shut; N' i$ P. q/ k$ }+ N

6 Z3 l1 V6 e7 [# j1 M$ yR1(confi g)#int e0/0
7 V8 l9 X4 B" ~: ]4 h$ B$ P0 _0 W& w- \6 Z$ L1 t& T- }  J* f6 N
R1(confi g-if)#no shut
7 q: A% J, ^. `
. {0 p  ^" \6 v- fR1(confi g)#int e0/0.1
! h& m5 [. O8 m% I- y$ c' P7 c- a0 X; e
R1(confi g-subif)#encapsulation dot1q 10: J* k5 c, {9 g; G0 F% S% J
/ L5 y) W" @2 C' L- D( r
R1(confi g-subif)#ip addr 192.168.1.1 255.255.255.00 I0 }( m0 Z, b0 L
0 S$ s3 u% U9 W. v2 V7 c; @# L
R1(confi g)#intE0/0.2
* I( h/ E3 Q" r8 t) Y
- v: H! q$ f; g& P7 o$ b" D  Z( WR1(confi g-subif)#encapsulation dot1q 20- d* r, c5 h+ P8 o6 j7 g2 P

& a, v8 J* u/ @* nR1(confi g-subif)#ip addr 192.168.2.1 255.255.255.0% ]: J% t. T( q9 w$ `! G
2 U5 u# T: O: g, D2 H: A
R1(confi g)#intE0/0.3
, ^9 Y* z6 M4 A6 ?. T2 i' q) l1 A4 A8 ]# Z
R1(confi g-subif)#encapsulation dot1q 303 _* Y/ [' w1 T3 c% _
$ Q5 |# `, o4 a7 ?8 \1 x
R1(confi g-subif)#ip addr 192.168.2.1 255.255.255.0
5 L! E3 d& |) ?, h
; i# N* P0 i, l$ E% [R1(confi g)# ip nat pool tian 172.16.1.1 172.16.1.1 netmask 255.255.255.0
* U! T' }, S5 P% c
& \$ }) q: ~+ h3 L/ R* k6 \: JR1(confi g)# access-list 10 permit 192.168.1.0 0.0.0.255" g& F) Z# j! s8 I2 S) D

) s4 ~; N; N$ i. C! T  C  RR1(confi g)# access-list 10 deny any
) S& M* L' Z( E) I& j$ m9 ?2 Q/ A
% |  N6 L* ?8 K1 T7 g) Y/ K8 r# gR1(confi g)# ip nat inside source list 10 pool tian overload
. b; q$ I) T' |6 C0 n
0 ?/ ?1 N( X7 M1 |! N: _R1(confi g)# int s1/0
& L& x' G6 O! d/ J' y) A7 x% ^
2 \9 E0 o2 Z1 n! W1 sR1(confi g-if)#ip nat outside3 u/ a* a9 J0 g( |- F" i5 u

% @2 y5 ]/ b/ I0 b, P: H4 KR1(confi g)# int e0/0.1
% p" x. G2 V4 Q7 P6 a, J5 r* z$ i# E. _8 v7 Y* x( }# ~
R1(confi g-if)#ip nat inside
  I7 d+ {0 q. N- @2 {2 N( |- |! v9 h9 ]6 {, T
R1(confi g)# ip nat pool chen 172.16.2.1 172.16.2.1 netmask 255.255.255.0
) i. z0 u, c' O# C7 z) {) e8 m: L5 }# x! I5 |! z$ Q
R1(confi g)# access-list 11 permit 192.168.2.0 0.0.0.255# M# U1 m- m$ F) ~9 _& n& z

6 m# ~3 v. ~- jR1(confi g)# access-list 11 permit 192.168.3.0 0.0.0.255/ p, o  v# ?1 n$ Y7 R4 Y! ^
% C" m2 b) v( C. m6 W. v
R1(confi g)# access-list 11 deny any
$ e7 q: Q' I/ X/ I( h2 R1 A; m8 h: O+ L! P1 K# c/ v; w( [+ v
R1(confi g)# ip nat inside source list 11 pool chen overload
; h7 n) @3 G/ L# V$ T( _5 e
5 h: |' s  n; ^# Y8 S$ D: eR1(confi g)# int s1/1
8 U) _" {& x! m1 X/ e  p; @: i; H! _  v- J, `6 L
R1(confi g-if)#ip nat outside3 w$ j" l- q; P/ r4 S2 t

$ S8 q. n  ^5 L2 c7 }) e3 l! Y3 IR1(confi g)# int e0/0.2
5 h% e  y# W9 C: i* F
- u7 g2 V" ^6 B  ZR1(confi g-if)#ip nat outside
1 e( ?( |- Q$ G% ?
4 X: n* u1 f" V4 Q4 R' x4 b9 {R1(confi g)# int e0/0.34 W: c4 m  p4 s  r; b) s

$ H! D4 w2 \) O: wR1(confi g-if)#ip nat outside* l: X' B+ y" O

& [, a6 b* Y4 i9 ^( ]4 r* t; P交换机配置步骤
" q" r7 L5 z/ P. L
& R3 y- a/ A! L3 HSw1(config)#int fa0/0/ \7 H. ^4 R+ X

  B1 S: }/ Y: ?Sw1(config-if)#switchport mode trunk
* a9 _' e* O2 Y1 S/ P+ V2 U2 [( v/ k4 W. e" z- d/ E
Sw1(vlan)#vlan 10 name gongchengbu) w; Z. l% l# {

% G. h- ^; |. c8 H* Z( K6 I5 ?Sw1(vlan)#vlan 20 name caiwubu$ s5 Q+ i2 o, Y* C0 |: Q

% V3 F8 u8 @) e, USw1(vlan)#vlan 20 name yuangongbu
1 d: b$ k: e& Y2 j( {; g) n) X" A+ b$ s5 Y# x& {# z9 \
Sw1(config)#int fa0/1; X0 |; `! l- W9 Y* I6 B

2 a+ K9 J1 C+ JSw1(config-if)#switchport access vlan 10
; y8 j! x. L$ J- ?/ T" B, A
- h$ c& V' Z) ~; W3 B7 T% ?: l: jSw1(config)#int fa0/2$ A) @$ S8 \' e' V& f' g
7 `& {9 @9 p' [4 K
Sw1(config-if)#switchport access vlan 20& {( P0 Q* a( j: O1 |9 i" l

- I; L+ Q! j. Y( {# ISw1(config)#int fa0/3) O& ?# n" Q7 D+ ~
5 V% c- @# |2 f
Sw1(config-if)#switchport access vlan 30% ]. I/ @& W3 P% |! B7 C0 u- w
. {2 e1 ?- j" Y( F" M+ P( T
Sw1(config)# int range f0/0 – 12
% [, d; g% S% G" A9 s
$ |' ]# F- w4 v8 M( f! b/ X/ mSw1(config-range)# no shut8 V6 \4 b8 o6 z
. W' X" h' ]' c( u3 Z- W0 F
PC机配置步骤:7 f9 b" k& `! l- k' q/ t5 f
5 f3 S, G  ^( Z8 i# _) |( q
PC1:C:>ip 192.168.1.2 192.168.1.1
: _* J$ C! p* o/ G6 g, y0 G
& Q5 `0 H5 R& @6 @PC2:C:> ip 192.168.2.2 192.168.2.1
; z1 ~( h% c8 m4 ~$ z( p
" U$ J# W- @  MPC3:C:> ip 192.168.3.2 192.168.3.14 B5 j4 i# ~0 q" K5 y  A% X
+ ~, i0 U, Q6 p+ S: j1 Q; o# B/ o
实现pc1 只能ping通172.16.1.2 不能ping通172.16.2.2$ J  L8 A( l- a9 ]; J- }% i

- h. l! V- w; m! R! ^9 V0 W0 r  G1 W实现pc2只能ping通 172.16.2.2 不能ping通172.16.1.25 z" p4 n8 j2 U$ S

$ g4 Q4 I" j$ p. h: P1 f实现pc3只能ping通 172.16.2.2 不能ping通172.16.1.2
 楼主| 发表于 2021-2-21 20:51:31 | 显示全部楼层
首先,安装cisco packet tracer软件,当前的版本应该是到了7点几了,我这边用的是6.2版本的,安装完成之后打开该软件,进入软件配置主界面!6 I- n$ {2 I! t: i. S
( u: t; y( S9 N4 B6 F" Q# c
接着,我们以cisco交换机3560-24ps为例讲述如何创建交换机的vlan。那么下一步就是添加cisco交换机3560-24Ps设备:点击“交换机”分类,然后选择cisco3560-24ps交换机,用鼠标拖到工作区间即可。7 q+ @& B3 o) c6 h  Q: @. M
http://www.bbs168x.cn/forum.php?mod=image&aid=193&size=300x300&key=038b21f6dd9fbad0&nocache=yes&type=fixnone
! X+ F. A5 z0 {& Q0 T( e3 g' h, c/ ]4 ^3 |/ h' ^( y2 i3 H1 h) W
然后,单击Cisco交换机3560-24ps进入“CLI”界面,输入“enable”命令进入特权配置模式。并输入“vlan database”命令进入vlan配置模式。
* L% O. v4 y5 _" t! C, s# bSwitch>en, o; c( p9 M1 T/ z5 t7 R
Switch#show vlan   A# }4 M+ f0 H: l7 m
* u, P( r8 F3 ~1 V4 x
VLAN Name                             Status    Ports
3 R5 j+ \8 _4 ~- E8 z( z---- -------------------------------- --------- -------------------------------
* Z. R+ @" ^' L: m: n9 }+ ]1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
3 n4 Z8 R0 |  V% T  h' l0 E                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
  p5 m. \/ ?  H! K0 I8 ?. ^, `0 Q                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
5 B& ]2 n; d- H9 s9 @9 A0 V                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16. d; D7 `# G4 i( a: a6 n. B2 O
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/207 @3 R$ D* B# [* Z. H7 ^  l# y
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
$ G2 ]6 q( V, [: t3 ?                                                Gig0/1, Gig0/29 M4 S* o1 Z9 S0 Y4 J0 t
1002 fddi-default                     act/unsup & ^0 D, f  d7 q/ N
1003 token-ring-default               act/unsup
, }' W1 a/ M* \1004 fddinet-default                  act/unsup / [) x8 n( i& m" S' `. L2 t) f# `
1005 trnet-default                    act/unsup & W' H- z9 c3 `4 K8 D9 C5 }
- i0 y1 v; Q) P6 n% b  R: g; n
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans21 w7 W1 O, \% V; D$ w- p
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------( B/ k2 Z1 G& d
1    enet  100001     1500  -      -      -        -    -        0      0
1 a- L, G3 M/ @1 t( Q4 u1002 fddi  101002     1500  -      -      -        -    -        0      0   
+ M  ~+ M7 ~; [1 T+ l3 u1 T( J1003 tr    101003     1500  -      -      -        -    -        0      0   4 R, t8 `4 [  _
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   % w, Y% ]  O+ v2 O
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   8 O0 |# K$ k! q6 Y: y/ L) S

4 _$ h( T* b/ uRemote SPAN VLANs  p/ o6 p$ O+ ], s0 }
------------------------------------------------------------------------------! p& i7 l0 r9 w3 V/ O7 L
$ H# Z2 [' b8 M* x0 h

4 c+ W1 Y% z; G; B9 xPrimary Secondary Type              Ports7 J0 ^% n' ?" J7 t
------- --------- ----------------- ------------------------------------------4 D0 K7 j# L; Z8 V. j% D
Switch#1 ]$ G' Q8 o- y6 U
5 K. t9 S7 G0 m* J6 f

  m5 z6 }' }$ L1 B2 e3 v
' i" b- z% B! q- q* HSwitch#vlan datab& G+ G5 Q9 Y9 m- d, n! c
% Warning: It is recommended to configure VLAN from config mode,! o$ m+ }& J0 a2 m, C
  as VLAN database mode is being deprecated. Please consult user: E' p! r) u" C" h3 S! U; h
  documentation for configuring VTP/VLAN in config mode.
3 Y' {8 m- v0 D: Z3 m% U4 q% _. S$ t/ I. S% A0 W$ J1 N4 r1 L
Switch(vlan)#
, J+ l* T7 `" R4 Q6 ^7 T2 T3 @, X0 v7 B# T
( d  H% ~9 b: L" N+ b
接着,进入vlan的配置模式后,输入命令“?”,可以查看当前模式下有哪些命令是可以使用的:
- `: `( d9 p# a3 ZSwitch(vlan)#?& _. L/ d+ f1 F$ I9 M9 k: q5 R; _
VLAN database editing buffer manipulation commands:
3 Q9 K0 ^4 T8 c  a+ q# `7 {& H  exit  Apply changes, bump revision number, and exit mode
' t: [/ u  G$ v: m0 G* `8 ?+ N  no    Negate a command or set its defaults5 D* y4 J4 t6 m  }* f
  vlan  Add, delete, or modify values associated with a single VLAN8 ?3 |; m* T) c' q
  vtp   Perform VTP administrative functions.
% u$ [% C1 o) `9 Y  I) I8 K6 a$ ]* m& Z8 [! B8 S- v+ G
exit:退出vlan模式;5 z6 u: ]+ O0 c: Z1 L) H* s

: O5 F! b" s2 z/ s% f9 J- u# Fno:删除某项vlan配置;2 L: }5 H+ T9 T2 @/ q9 L

- M' w, ]3 U) T$ vvlan:vlan模式下更深入的配置;9 ^: ~! G# Q8 a5 C- _" }

  x, r( w1 Y/ V8 D; n* B0 t& u6 Wvtp:vlan下面vtp域的配置;. x' d! `4 A) U3 H/ n" S

9 s3 Y  t9 [( _5 q9 W% w& B
, K3 _( ^4 }/ q3 O  j然后,我们开始为cisco交换机添加一个vlan 1000,那么直接运行命令”vlan 1000“即可。/ h3 G8 ~! d. p3 c$ ^) d
Switch(vlan)#vlan 10008 ~6 A. c7 L8 y  H1 w
VLAN 1000 added:
" P4 C  Y) W, p2 |( w6 P+ e$ v    Name: VLAN1000, R  q3 Q$ c& H7 F9 P6 S/ F
- L( r8 c( S- X* G1 G
$ a8 i6 Q: Z1 ~- U

' z; ^9 ^1 C+ p" H# ^" p& i/ R接着,我们执行”exit“命令退出vlan配置模式,8 {) u% F! R  U' {3 C8 y, Y
Switch(vlan)#exit
! W2 U$ h5 A5 W& q% h# R6 pAPPLY completed.5 U5 W% w' ]7 S- Z' t
Exiting....9 ?; `0 {& V& n6 h0 B; p0 k
( l8 x+ X" j5 R8 ]. q0 x  a5 D
1 m5 R% k1 `% ?2 ?
执行命令”show vlan“在特权模式下查看cisco交换机的所有vlan信息。可以发现交换机已经添加了我们需要的vlan 1000。
1 R( v5 Z! R- B! Z
/ q2 H& ]! E3 f% v2 oSwitch#show vlan
- T( ]8 E, l/ y0 _7 m1 W" f
) F1 i, ^  p; m' f; SVLAN Name                             Status    Ports
' S) g% u( E5 d6 O8 [! e5 [! c4 l---- -------------------------------- --------- -------------------------------
/ R' Y* n$ V; X) z1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
" z' r. k& a8 K6 H: M$ ^' F4 g                                                Fa0/5, Fa0/6, Fa0/7, Fa0/87 J7 E9 h$ H- ~+ o* }  ?3 r4 Q
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
7 d1 T; C" k( A8 V                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16! Y/ w2 a* \: f+ W0 I; n
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20$ x" v, f4 y  ~( L
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
0 H# E! Y. R! I7 A- n/ Y                                                Gig0/1, Gig0/2
9 R. n( S5 x0 O, ^8 c2 B% n1000 VLAN1000                         active    $ E" t2 B+ R5 V  B
1002 fddi-default                     act/unsup % C4 q. }( Q$ H, k
1003 token-ring-default               act/unsup
+ Y* n7 x1 b; y1004 fddinet-default                  act/unsup
1 k( W$ t& t7 j1005 trnet-default                    act/unsup
2 V4 G5 z1 T/ t! Z# @4 b" A7 E& Y  T# W* i4 ~; P, I4 V
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2. ^( e7 h6 n6 A- J  R
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
: O7 h2 R8 x5 m- f& M- a3 h1    enet  100001     1500  -      -      -        -    -        0      09 Q3 ^! f3 ^/ D! J. H5 Z1 ^
1000 enet  101000     1500  -      -      -        -    -        0      0; |" G+ z! q1 W% k
1002 fddi  101002     1500  -      -      -        -    -        0      0   
7 P! `- _1 K" a1003 tr    101003     1500  -      -      -        -    -        0      0   
- s+ o& c) j5 z/ [7 V1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
/ h! C% W5 Q" [- K3 ?( J$ ~; s1005 trnet 101005     1500  -      -      -        ibm  -        0      0   $ K+ M/ b6 H: J4 i0 G
- K  T% z7 B9 a+ t8 W
Remote SPAN VLANs
# A& K: g) X& }% f- W1 s% Q' B------------------------------------------------------------------------------" r0 l. Y# }) ]' i# \- C; h; p7 W, R5 }8 S
( z  }) Q! |7 u& L9 [

: V" i9 E% `6 Z6 d- qPrimary Secondary Type              Ports
/ @2 S3 p+ `. R+ |------- --------- ----------------- ------------------------------------------, h2 c; @% f; a! P. }

4 v1 n( w! |3 U; m" m% m& h0 i; d
然后,vlan已经添加,但还没有任何交换机的接口归属于这个vlan,也就是说这个vlan没有任何意义。所以,下一步就是添加一个交换机接口到这个vlan 1000。9 h+ r1 g2 F  [# G

( P' \8 D; u, a0 r- |# W进入全局配置模式,
6 D9 L% u; F: K0 r9 |$ E1 Q7 N, A5 u+ S: l
Switch#conf t# B6 ]" `5 S  [9 ?: L
Enter configuration commands, one per line.  End with CNTL/Z.) Q8 u* g' c! b" g/ [: c. J) C4 l
把Fa0/1接口的模式配置为access,并归属于vlan 1000,具体命令为:
- _" I$ z; e8 N5 H0 _! @3 D) I" W, R$ H7 ], J* L
Switch(config)#int fa0/1
2 y/ f/ w5 E, @1 X2 F8 K+ O
: [, f$ t% P' g& Q8 K8 X1 LSwitch(config-if)#switchport mode access
6 O/ I4 S! f4 E; ?
+ b1 P0 D# F5 f  t: @/ JSwitch(config-if)#switchport access vlan 1000& [& u) d0 y1 Z$ j- i
: A3 e6 a8 X7 l" k- q* S
7 O5 j' f2 X/ g. o& x$ L
接着,回到特权模式,执行命令”show vlan“查看当前的vlan配置信息,可以发现,接口Fa0/1已经被划分到了vlan 1000。* y. A0 D! }  F6 Q+ @6 W
Switch(config-if)#exit/ a+ P5 p2 Y5 o+ I
Switch(config)#
# ?+ g! i7 S! E, a8 B) ]
# C8 T. c6 @7 i5 `1 m7 z然后,就是配置vlan 1000的IP地址信息了,执行命令:; u( K( Y4 U  m6 |) V

, ~! n* I/ Y! _* {0 J) y0 HSwitch(config)#int vlan 1000
1 P, }/ q+ [/ H8 ~" H; {# r; R+ R% s3 ^) \4 v
Switch(config-if)#ip address 192.168.100.1 255.255.255.0
7 N0 m" U, r' a2 q, r7 ]% Q  x) {8 x6 p
Switch(config-if)#exit9 @0 a3 A0 i' _/ \1 r$ Z
/ a5 `, V; C5 d' J% T, c- K7 W) B
' O7 E1 k) O* L, S
最后,在特权模式下,
2 g( d. `2 G8 G. v9 qSwitch(config)#exit) }  {% ]& v+ _9 H
Switch#
6 C- `4 y; [" l
$ L, O: q  L4 H( z! ^7 `0 D9 o执行命令”show running-config“查看vlan的相关信息。到这里,整个vlan的配置过程就完成了。
' c5 S: ]) m1 h/ z, i0 H4 DSwitch#show running-config 2 v2 u4 s; j! j: k
Building configuration...
. c( |( b/ x9 p# N/ R( PCurrent configuration : 1196 bytes
; V0 a7 M" a1 J& v) N) s& h) V6 t6 O!" c( p( u7 E/ ~% v8 E8 z
version 12.2& E; ~( }' }1 {" d3 v$ |7 \
no service timestamps log datetime msec
$ K# s% q4 V3 w' O, \no service timestamps debug datetime msec! `1 k9 H- P  M& T0 \+ }0 b
no service password-encryption
) {0 V  [1 R" \  ?  E5 j!
1 T  R! X: ~& p. L) w5 `hostname Switch$ s  B/ |7 v6 G- w
!! J$ b% f  z; v. o: ]1 t
!
  R. z3 x% s8 |1 b) ~8 [1 r# ?!9 l) V/ J( Q- w# ^& `+ i: j
!
% S/ A, {5 q+ G) I5 Q0 t0 J2 a!
6 ~! E3 N/ B3 A. w) G!; v' D! w' y: F/ ~+ l9 n
!
1 q: l' l. t9 A7 P1 U: n!$ A3 y8 w9 @# e2 o% X
!; O6 f. l3 p4 i/ }; t
!
) X6 r' k/ j3 k2 K9 B' v!
* Y4 y. F0 S  D8 i5 h; \!
3 C( l+ {3 ^" c1 @' a% P!
: }4 @4 g5 G) V8 L!  B) p/ K1 {; W( ?# U
spanning-tree mode pvst
% @: }! C5 G* B!
5 D4 o; I  M' i* X/ F& {!0 C; b2 [! [! N5 ~
!& b3 u% Y" K; o( W, w$ n0 {
!0 D! E% I3 v4 e4 p( s
interface FastEthernet0/1
# m) z/ o: c3 e3 J6 z- j switchport access vlan 1000
0 Q' `' Y2 E1 A, {  ^5 L9 V/ l( N switchport mode access/ ~' C! C9 |" D* H
!! i; D; [) H6 G5 v$ N& a# |
interface FastEthernet0/2
( M- {" x# E3 I- k8 S; `! k!; \9 K/ ~% E- ^& X4 t$ c* a
interface FastEthernet0/31 I: p; `" z+ F* v7 ^. x4 j% k
!  ?5 k5 w: F( ^+ B6 s" w
interface FastEthernet0/45 z& Q* z2 k1 h$ _% V; A$ `
!, a9 M  }% g5 I2 e% d
interface FastEthernet0/5/ G! n; f, K+ z, K4 X) i( l
!0 I: T) D# Z( n
interface FastEthernet0/6
9 V6 q* v& |7 V7 R8 B1 [& i!
1 [, w" R' r* [# h" O" \, D1 cinterface FastEthernet0/7" B, i8 d2 f, B& Y
!
% r+ m$ Y% L1 M% Y- }; \interface FastEthernet0/8. [6 z$ a+ g5 T9 \) o% C, i
!+ r" {! d; {. ^% |1 h) p* g, a" P
interface FastEthernet0/9
4 X) ~6 [6 v: f% B) E!
, _* f% W" A8 r: c% A# C3 einterface FastEthernet0/10
* s# l: E, N8 z1 x5 a; b6 Q# g0 G!
9 p( ~% j+ _! ~$ A& uinterface FastEthernet0/11
7 q6 x9 z8 b" [2 \" Q!5 W5 i+ ]7 F6 \9 `
interface FastEthernet0/12
- h! R, x- }5 l9 l- ?& W( G- d9 L!
! a5 A- H# u3 T0 n- u6 k1 g" T5 g: [interface FastEthernet0/136 s/ ~: a" ]- ?3 E8 m5 W$ r2 O+ G' }
!$ Y1 d# f7 x- {3 b
interface FastEthernet0/14
# E8 o- [7 d5 A% R9 b- Q!6 w: U- y4 v  T! P4 B4 G  V
interface FastEthernet0/15
2 o' T# L) ], D9 g8 @$ C) l8 Q!5 ^! w/ _  p2 @
interface FastEthernet0/16
4 A6 R: K9 ~' a' a8 `!4 C: j' H9 B: C: t
interface FastEthernet0/17' X; {* n$ O: e0 H8 Y- ?
!
! D  H8 _& T4 s2 \+ f: m2 M, {interface FastEthernet0/188 R( f4 R2 m# h/ k
!/ b5 }/ D4 J( o* c) j6 w2 P
interface FastEthernet0/190 M# ^  D$ Q6 Q+ z+ X. u( a
!
4 Q0 J' h' y9 x8 uinterface FastEthernet0/20
- p' L& u* ^1 z1 C!
9 d& Y0 M* i9 \6 m7 A9 Rinterface FastEthernet0/21
& J1 }* l3 K7 N3 Z!
% G& V7 q- s  p; l% m& Binterface FastEthernet0/227 t! }9 Z; ~1 g$ ~) E! ^
!- L, v0 b5 k3 _2 L$ N1 l
interface FastEthernet0/23
7 S  b, o' V8 Q!
9 J5 y0 X4 N, o1 `interface FastEthernet0/24
! ]% q7 o5 z9 t- Q4 j; N!
  D& ]# M1 R1 Q) z" o1 _6 ginterface GigabitEthernet0/1
' _, i1 j  P. i1 }/ Q0 }: d!; ^/ \& \  y) K( Z3 ?) [# D! F2 G
interface GigabitEthernet0/21 s1 [8 o' b1 Y, z" L
!2 y- ]% U8 {7 q3 K; q9 O5 T
interface Vlan1
  V7 @" _. D) P; t& F8 }: c no ip address
! G2 K4 r. t9 p9 M7 E$ i0 \ shutdown0 Q6 H: T3 k9 D. @
!
, F# x1 J3 R; P0 L8 N! |5 K* V$ finterface Vlan1000' a5 H9 p0 K; |$ F
ip address 192.168.100.1 255.255.255.0" X% P& t/ P! V) R% p2 T
!
' M9 s* ]2 j. h7 Z, h% s9 _% Eip classless
* t9 ~; j' `/ a: U!
/ n% U2 B* E8 T6 _!
* W9 ]9 b! {! Q9 s2 K!" C! t1 @, p% W! ?' w, n! U0 }* g
!* T2 i4 I0 t" s3 z( @) h- a% _8 y! N/ Q
!/ y/ Z" P& W  {$ M# U
!
# n$ @) O! K9 v+ q!
2 w6 n- x- p* l$ c. l6 u& ^line con 0
+ M' B+ ~" B9 }$ ^; K6 l0 q!9 n( G* B! @  E0 n2 L
line aux 0$ u1 v- `" J: a
!% l* w" M' v3 D" _! ?" F  {
line vty 0 4# W0 S. n4 v1 f
login
- I6 m, I: _6 d$ T!
3 p9 l1 ^. Z. W* f5 A# S9 y+ E$ m!
( P4 d1 t4 j, `!
8 E: _& E/ k' A+ xend
  l, B) d3 {; R3 l- H" b* N1 O
2 f; P9 \" n4 @& p( eSwitch#
" d5 u$ d1 x! h, [/ O. ?% d% p' s
4 o0 |% r: O* q5 C1 a* f* K
% R/ x$ l: R* D
8 k( P. }) Z2 ?- i5 {7 G
图一添加.png
 楼主| 发表于 2021-2-21 21:20:46 | 显示全部楼层
有两种解决方式,可以让你思科3750和TP-LINK相连。
/ {) _0 j; E/ [$ p* N7 ?7 q第一种:3750与TP-LINK相连的bai物理端口,手工改变端口类型,二层变成三层。
6 _0 j; J' N* b2 p思科的3750属于三层交换,物理端口可以从二层转成三层,也就是端口端口上是可以配置IP地址的。假设TP-LINK的LAN口IP地址为192.168.1.1/24,与思科3750的GE0/1相连。那么在思科上配置如下命令:
: y/ \6 d7 ~4 S: Dinterface gig0/1) u  Z% j- ^& @! H  ?
no switchport  g5 W* F5 F( k' j
ip address 192.168.1.2 255.255.255.0
5 ?8 Z( b. c! N6 b4 ^+ T+ g. b此时,这个端口将从二层变成三层,与TP-Link的LAN口连接。
! @+ f4 w8 _0 i. d, J1 ^第二种:3750与TP-LINK相连的物理端口,封装802.1q,起trunk,然后该接口的本征VLAN,让一个拥有最大的权限的VLAN作为本征VLAN,别的VLAN想上网,那么首先要通过那个权限最大的VLAN,然后才能出去。使用权限最大那个VLAN的SVI 接口的IP地址与TP-LINK的LAN IP通讯(最大VLAN的网段必须和TP-LINK的LAN口同一个网段)。
5 |8 T' B, b' Q$ E. D# f5 c假设:3750权限最大的VLAN 是VLAN 10,3750的GE0/1接口与TP-LINK互联
6 I# y, }3 r' t+ P4 C2 pint vlan 10
% g+ `1 }8 @9 D$ f7 nip address 192.168.1.2 255.255.255.0
/ U& d$ h" S: t' ^2 mno shutdown
: L8 \8 _( F4 Wexit
8 L* R6 y  D! S- a" U* o' aint gig0/1" k$ l$ P1 E2 g: [  x
switchport trunk encapsulation dot1q
. G7 M- W+ K5 \) K+ qswitchport mode trunk% J& n5 m; a$ s" G
switchport trunk native vlan 103 Q% D, u4 `. W8 j% W
如上,两种方法能和TP-LINK互联,也学要在3750写默认路由才可以出去外网:
9 R  }) t- i0 J/ k# U6 i5 Z假设TP-LINK的LAN口的IP:192.168.1.1/24
( U; O, q+ H  |$ ^' S那么3750上:
) S! o" t+ x! K9 _$ V  Xip route 0.0.0.0 0.0.0.0 192.168.1.1
5 N& x8 N) k9 t差不多配置到此就可以了。
 楼主| 发表于 2021-2-21 21:31:36 | 显示全部楼层
有两种解决方式,可以让你思科3750和TP-LINK相连。
6 b" G, F+ j. X9 c第一种:3750与TP-LINK相连的bai物理端口,手工改变端口类型,二层变成三层。3 |5 ]3 j$ s: U
思科的3750属于三层交换,物理端口可以从二层转成三层,也就是端口端口上是可以配置IP地址的。假设TP-LINK的LAN口IP地址为192.168.1.1/24,与思科3750的GE0/1相连。那么在思科上配置如下命令:$ M0 u/ O* L; _. o9 f
interface gig0/1* ?5 b3 J2 a6 [0 I( ~
no switchport
% A  J1 z+ o  Y( G! jip address 192.168.1.2 255.255.255.0) f& `7 ^8 _6 l" Y5 F
此时,这个端口将从二层变成三层,与TP-Link的LAN口连接。
+ q! D/ L0 e0 L! G! D( s0 E9 o第二种:3750与TP-LINK相连的物理端口,封装802.1q,起trunk,然后该接口的本征VLAN,让一个拥有最大的权限的VLAN作为本征VLAN,别的VLAN想上网,那么首先要通过那个权限最大的VLAN,然后才能出去。使用权限最大那个VLAN的SVI 接口的IP地址与TP-LINK的LAN IP通讯(最大VLAN的网段必须和TP-LINK的LAN口同一个网段)。
# I- D' J8 P& X假设:3750权限最大的VLAN 是VLAN 10,3750的GE0/1接口与TP-LINK互联
+ z8 l3 w# |3 J* ~( nint vlan 10
8 [/ M* C; ?7 C0 i$ s. I1 fip address 192.168.1.2 255.255.255.0
9 Q& s) b: p) J6 Z2 |( C; t/ S! vno shutdown
0 z# e7 B( i- T* Z8 n* [6 Dexit
$ e- X7 g9 J% {4 {int gig0/12 u/ p+ S, }. J* @, ~: b+ |
switchport trunk encapsulation dot1q! R' X( f! q, \- Z: G4 K$ V
switchport mode trunk; o4 q5 I, S5 r
switchport trunk native vlan 10# U" @" Y; Y+ d0 i) Y% L: O
如上,两种方法能和TP-LINK互联,也学要在3750写默认路由才可以出去外网:8 D: @1 z" \+ Q! M7 p+ E* z
假设TP-LINK的LAN口的IP:192.168.1.1/24
4 \) G7 e* y: s* Z那么3750上:% U- q  e8 C5 C3 p
ip route 0.0.0.0 0.0.0.0 192.168.1.1: U3 T1 z, b3 p
差不多配置到此就可以了。
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-4-13 08:44 , Processed in 0.069504 second(s), 26 queries .

Powered by 龙睿 bbs168x X3.2

© 2001-2020 Comsenz Inc.

快速回复 返回顶部 返回列表