将设为首页浏览此站
开启辅助访问 天气与日历 收藏本站联系我们切换到窄版

易陆发现论坛

 找回密码
 开始注册
查看: 187|回复: 1
收起左侧

cicso路由器接入公网的配置

[复制链接]
发表于 2021-2-20 22:25:48 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?开始注册

x

路由器接入公网的配置方法

电信宽带为2M, 分配给的固定IP地址:202.249.11.101 子网掩码:255.255.255.248 网关:202.249.11.20 局域网规划地址范围为: 192.168.0.2 - 192.168.0.254 子

网掩码:255.255.255.248 网关:192.168.0.1 路由器为Cisco 1841

配置过程如下:

Router>en            //进入特权配置模式

Router#configure terminal                         //进入全局配置模式

Router<config>#interface FastEthernet 0/0       //配置0/0为内网端口

Router<config-if>#ip address 192.168.0.1 255.255.255.0           //指定内网端口的IP地址及子网掩码

Router<config-if>#ip nat inside              //将该端口定义为地址转换(NAT)的“内部端口”

Router<config-if>#no shutdown            //使该端口处于“运行”状态

Router<config-if>#exit                             //返回

Router<config>#interface Ethernet 0/1                //配置0/1为外网端口

Router<config-if>#ip address 202.249.11.101 255.255.255.248             //指定外网IP地址及子网掩码

Router<config-if>#ip nat outside            //将该端口定义为地址转换(NAT)的“外部端口”

Router<config-if>#no shutdown           //使该端口处于“运行”状态

Router<config-if>#exit                 //返回

Router<config>#ip route 0.0.0.0 0.0.0.0 202.249.11.20                 //定义路由地址

Router<config>#no access-list 1                       //我们先取消出厂状态下的访问控制列表“1”,默认的访问控制列表是空的,所以要取消掉,重新定义

Router<config>#access-list 1 permit 192.168.0.0 0.0.0.255                    //重新定义访问控制列表“1”为“允许192.168.0.0/24的网段”

Router<config>#ip nat pool nanpool 202.249.11.97 202.249.11.102 netmask 255.255.255.248                  //定义从ISP供应商那里申请到的公网IP地址在企业内部的分配策略,

          在这里我们定义了一个地址池,名称为“nanpool”,在这个池里所定义的 IP地址(202.249.11.97到202.249.11.102)将被内网的用户用来上网。如果ISP只给了

  你一个IP地址(如202.249.11.101),那你可以在这里写成  ip nat pool nanpool 202.249.11.101 202.249.11.101 netmask 255.255.255.248

3 x: ]& z1 J  C9 z

Router<config>#ip nat inside source list 1 pool nanpool overload              //将访问控制列表“1”与地址池“nanpool”进行对应式绑定。意思是说所有“192.168.0.0”

网段内的用户在上网时,它的内网地址都将被转换为“202.249.11.97 - 202.249.11.102”中的任意一个外网地址。后面的“overload”则表示,如果有多

于地址池中定义的地址数量(比如原来有6个用户上网,他们各自所用的外网地址是202.249.11.97 、202.249.11.98、202.249.11.99、202.249.11.100、

202.249.11.101、 202.249.11.102。而现在突然有30个用户上网了,这时就会按照上面的命令执行一个任务,那就是让多个内网用户使用同一个外网地址。

 楼主| 发表于 2021-2-20 22:25:54 | 显示全部楼层
有两种解决方式,可以让你思科3750和TP-LINK相连。& f& n$ u% W4 m+ x" p5 x8 I6 l: A& _
第一种:3750与TP-LINK相连的物理端口,手工改变bai端口类型,二层变成三层。9 N  g5 h9 E$ {2 Y4 z
思科的3750属于三层交换,物理端口可以从二层转成三层,也就是端口端口上是可以配置IP地址的。假设TP-LINK的LAN口IP地址为192.168.1.1/24,与思科3750的GE0/1相连。那么在思科上配置如下命令:
% [% o4 v! ]/ I1 @2 k8 u' Y9 |4 L, jinterface gig0/14 \$ q4 ?4 m# Q8 n
no switchport
9 o/ z4 v/ K1 N- p% |ip address 192.168.1.2 255.255.255.0
# q+ R- g1 |" x7 i此时,这个端口将从二层变成三层,与TP-Link的LAN口连接。5 Z' s8 F( J$ |+ C
第二种:3750与TP-LINK相连的物理端口,封装802.1q,起trunk,然后该接口的本征VLAN,让一个拥有最大的权限的VLAN作为本征VLAN,别的VLAN想上网,那么首先要通过那个权限最大的VLAN,然后才能出去。使用权限最大那个VLAN的SVI 接口的IP地址与TP-LINK的LAN IP通讯(最大VLAN的网段必须和TP-LINK的LAN口同一个网段)。
- {8 K% ^! t7 h* l6 W2 l  t, q, |假设:3750权限最大的VLAN 是VLAN 10,3750的GE0/1接口与TP-LINK互联
( c* k/ {# h0 J& M5 T4 Yint vlan 10
  m: ?: F, V  k. I! E( eip address 192.168.1.2 255.255.255.0
0 y! X5 \* O; Q0 A- |% R; Gno shutdown) y4 f! P0 y& A! I. g5 t
exit
7 X. o& V+ }$ l$ O; ?int gig0/1
$ i! j  `) @9 |; _% [0 s) Sswitchport trunk encapsulation dot1q9 p7 |: i5 K" \  G% j: ?
switchport mode trunk
4 `! w7 [  Q, T* Jswitchport trunk native vlan 10
3 \6 _- n% z3 |, ?  x! C6 U* T如上,两种方法能和TP-LINK互联,也学要在3750写默认路由才可以出去外网:$ `, X0 M3 \6 B$ n
假设TP-LINK的LAN口的IP:192.168.1.1/24  c) k% I# G8 J
那么3750上:- P, z, ^5 w% Y) Q7 r- j3 C
ip route 0.0.0.0 0.0.0.0 192.168.1.1
您需要登录后才可以回帖 登录 | 开始注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

如有购买积分卡请联系497906712

QQ|返回首页|Archiver|手机版|小黑屋|易陆发现 点击这里给我发消息

GMT+8, 2021-4-13 08:39 , Processed in 0.060677 second(s), 22 queries .

Powered by 龙睿 bbs168x X3.2

© 2001-2020 Comsenz Inc.

快速回复 返回顶部 返回列表